EntrustedMail - Microsoft 365 recipients notification messages for secure messages are being delivered to the recipients Junk Email Folder. – Incident details

All systems operational

Microsoft 365 recipients notification messages for secure messages are being delivered to the recipients Junk Email Folder.

Resolved
Operational
Started over 2 years agoLasted 12 days

Affected

EntrustedMail Secure Portals

Operational from 3:07 PM to 1:21 PM

EntrustedMail NA Region Secure Message Portal

Operational from 3:07 PM to 1:21 PM

Updates
  • Resolved
    Resolved

    Secure portal notification messages being routed to the Junk folder, for Microsoft 365 recipients, has been marked as resolved.

    Our apologizes for the inconvenience caused by this event.

  • Monitoring
    Monitoring

    Our network team, working with Microsoft 365 engineers, have resolved this issue. Secure portal notification messages are no longer being routed to the Junk folder, for Microsoft 365 recipients, as a result of this issue.

    Our apologizes for the inconvenience caused by this event.

  • Identified
    Identified

    We are continuing to work with Microsoft on this issue. Microsoft engineers are running diagnostics at the back end; unfortunately, the diagnostic efforts take time to propagate throughout the Microsoft 365 environment.

    The next update will be provided within 24 hours.

  • Investigating
    Investigating

    Secure Portal Notification Messages, delivered to recipients using Microsoft 365, are being delivered to the Junk Email folder.

    We are currently investigating this incident.