Scheduled Network Maintenance - October 18th 2025
Scheduled for October 19, 2025 at 3:00 AM – 5:00 AM
Affects
EntrustedMail Access Management Portal
Under maintenance from 3:00 AM to 5:00 AM
EntrustedMail Email Archiving
Under maintenance from 3:00 AM to 5:00 AM
EntrustedMail Encryption Gateways
Under maintenance from 3:00 AM to 5:00 AM
EntrustedMail US Region Encryption Gateway
Under maintenance from 3:00 AM to 5:00 AM
EntrustedMail EU Region Encryption Gateway
Under maintenance from 3:00 AM to 5:00 AM
Secure Cloud (Zix)
Under maintenance from 3:00 AM to 5:00 AM
- Completed October 19, 2025 at 5:00 AM
- Completed - October 19, 2025 at 5:00 AM- Maintenance has completed successfully 
 
- In progress October 19, 2025 at 3:00 AM
- In progress - October 19, 2025 at 3:00 AM- Maintenance is now in progress 
 
- Planned October 19, 2025 at 3:00 AM
- Planned - October 19, 2025 at 3:00 AM- Affected Services - ·         Network connectivity - Affected Users / Customers - ·         Customers utilizing EntrustedMail services. - Expected Impact - ·         Brief periods of increased latency or packet loss may occur during de-peering and re-peering. - ·         No significant service interruption is expected. - Reason for Maintenance - ·         One of our upstream network providers will be performing required maintenance. - ·         To minimize customer impact, our engineers will proactively de-peer from this provider and re-peer once the maintenance is complete. - Actions Required - ·         No action is required from customers.